Directory Core/Util/

Total Files:
36
Deleted Files:
4
Lines of Code:
4327

[root]/Core/Util
            directory in repo Timers (1 files, 328 lines)

Lines of Code

Core/Util/ Lines of Code

Developers

Author Changes Lines of Code Lines per Change
Totals 104 (100.0%) 603 (100.0%) 5.7
ahumphrey 16 (15.4%) 216 (35.8%) 13.5
allen 12 (11.5%) 189 (31.3%) 15.7
dav 3 (2.9%) 144 (23.9%) 48.0
jas 66 (63.5%) 38 (6.3%) 0.5
guilkey 3 (2.9%) 10 (1.7%) 3.3
harman 1 (1.0%) 4 (0.7%) 4.0
jthornoc 2 (1.9%) 1 (0.2%) 0.5
bpeterson 1 (1.0%) 1 (0.2%) 1.0

Most Recent Commits

ahumphrey 2017-12-21 21:35 Rev.: 57513

VarLabel: DebugStream --> Dout so info is legible when output by multiple threads.
Other cleanup and refactoring.

59 lines of code changed in 2 files:

  • Core/Util: InfoMapper.h (new)
ahumphrey 2017-12-19 15:29 Rev.: 57481

* Finish repairs and cleanup in Core/Malloc, specifically the Uintah default Allocator (when SCI_MALLOC is enabled). Remove legacy pthread code, recursive locks, etc. Use std::mutex, no need for recursive mutex.

* Remove sci_system, use std:system

* Remove all remaining pthread remnants (including THREAD_LIBRARY references). Only use and rely on std::thread. Should have never been mixing pthreads with std::thread. Can't bank on what the underlying thread impl is.

* Generate new configure script.

* Lastly, fix issue with MPM PetscSolver include. Now Uintah compiles without Petsc (e.g. --without-petsc), as it should be able to.

67 lines of code changed in 10 files:

  • Core/Util: Environment.cc (new), Environment.h (+1 -3), FileUtils.cc (new), sci_system.cc (del), sci_system.h (del), sub.mk (new)
bpeterson 2017-12-18 16:01 Rev.: 57472

Dav and I chatted about this. Ubuntu 17 has issues when compiling this file, which we think is caused by a bug in 2.26. Our "fix" for now is just to put a comment in that file giving the user an alternative edit that will get Uintah to compile. A future fix would be an additional #ifdef check to make this automatic

1 lines of code changed in 1 file:

  • Core/Util: sci_system.cc (new 1)
jthornoc 2017-11-28 17:55 Rev.: 57362

* Added a equation class to the equation groups to help manage the different scalar types (mixture fraction, DQMOM, etc…)
* Minor spacing, tabs, etc…
* Added an include in Endian.h as I had a couple compilers not being able to identify the IntVector type.

1 lines of code changed in 2 files:

  • Core/Util: Endian.cc (new)
guilkey 2017-11-07 17:58 Rev.: 57245

Add IntVector to the variables that have a swapbytes defined. Also added a
comment directing the next person to edit testEndian.h.in to get changes to
Endian.h. Thanks to Dav and Biswajit for their help.

10 lines of code changed in 3 files:

  • Core/Util: Endian.cc (+8), testEndian.h.in (new)
allen 2017-10-25 12:48 Rev.: 57176

added processor node identification to the proc group, also cleaned up method names

177 lines of code changed in 1 file:

  • Core/Util: InfoMapper.h (+177 -82)
allen 2017-09-12 14:12 Rev.: 56986

added specified z library

1 lines of code changed in 1 file:

  • Core/Util: sub.mk (+1 -1)
allen 2017-07-31 14:29 Rev.: 56834

removed the active status from the name, because it can change, also the semi-colon messes up the parsing for the in-situ

0 lines of code changed in 2 files:

  • Core/Util: DOUT.hpp (new)
ahumphrey 2017-07-14 18:13 Rev.: 56794

Fix name shadowing issue in DOUT variadic macro.

23 lines of code changed in 1 file:

  • Core/Util: DOUT.hpp (+23 -23)
ahumphrey 2017-07-14 13:38 Rev.: 56793

Revert DOUT.hpp to original, nearly pristine state.
Recommendation is to use explicit operator bool() for checking active state, but left active method in with coments.
Some other minor cleanup.

12 lines of code changed in 1 file:

  • Core/Util: DOUT.hpp (+12 -12)
harman 2017-07-14 12:27 Rev.: 56792

Grid::printStatistics()
- added debug stream (GRID) that output patch extents

environmentalFlags.txt
- additional entries and organization.

DOUT.hpp
- fixed a bug, the first SCI_DEBUG name listed is properly read and processed.

4 lines of code changed in 1 file:

  • Core/Util: DOUT.hpp (+4 -3)
ahumphrey 2017-06-22 22:12 Rev.: 56693

More refinement and fixes for infrastructure timings.
Other misc cleanup.

23 lines of code changed in 1 file:

  • Core/Util: InfoMapper.h (+23 -26)
allen 2017-05-24 07:41 Rev.: 56567

removed the colon and active bit to where it is really needed

2 lines of code changed in 1 file:

  • Core/Util: DOUT.hpp (+2 -2)
allen 2017-05-15 16:37 Rev.: 56530

type change tounsigned

4 lines of code changed in 1 file:

  • Core/Util: InfoMapper.h (+4 -3)
allen 2017-05-15 16:20 Rev.: 56527

added get/set methods for the active state

2 lines of code changed in 1 file:

  • Core/Util: DOUT.hpp (+2)
allen 2017-04-26 16:35 Rev.: 56486

added check for empty stats

3 lines of code changed in 1 file:

  • Core/Util: InfoMapper.h (+3)
ahumphrey 2017-04-25 22:40 Rev.: 56480

* Significant cleanup for RuntimeStats usage. Correspondingly, this cleans up the execute() methods for all schedulers.

* Consolidate Dout objects in RuntimeStats class - MPIStats, WaitTimes, and coopted ExecTimes SCI_DEBUG env vars now all work well. Note that MPIStats makes use of the individual timers for each MPI call in UintahMPI.h. This is the most accurate, per-MPI-call info we can get, e.g. Count, Time and number of messages for several message size categories.

* runTask() methods in MPIScheduler and UnifiedScheduler now feed the loadblancer contribution and exectimes map the same values (task execution time from beginning of doit() to end of done() ), computed by the DetailedTasks themselves.

* Removed more usage of usingMPI() condition. This method will ultimately be removed as it is meaningless now, because Uintah is always "usingMPI", meaning for even 1 MPI proc runs, Uintah inits the MPI runtime.

* Updated environmentalFlags.txt to reflect new offerings from RuntimeStats class.

32 lines of code changed in 1 file:

  • Core/Util: InfoMapper.h (+32 -32)
jas 2017-04-20 13:18 Rev.: 56452

Update copyright.

38 lines of code changed in 66 files:

  • Core/Util: Assert.h (+1 -1), DOUT.hpp (+1 -1), DebugStream.cc (+1 -1), DebugStream.h (+1 -1), Endian.cc (+1 -1), Environment.cc (+1 -1), Environment.h (+1 -1), FancyAssert.h (new), FileUtils.cc (+1 -1), FileUtils.h (+1 -1), GPU.cu (+1 -1), GPU.h (+1 -1), Handle.h (+1 -1), InfoMapper.h (+1 -1), NotFinished.h (+1 -1), ProgressiveWarning.cc (+1 -1), ProgressiveWarning.h (new), RWS.cc (new), RWS.h (new), RefCounted.cc (new), RefCounted.h (new), RefCounted_gcc.cc (+1 -1), SizeTypeConvert.cc (new), SizeTypeConvert.h (+1 -1), StringUtil.cc (new), StringUtil.h (new), TupleHelpers.hpp (+1 -1), Util.cc (+1 -1), XMLUtils.cc (new), XMLUtils.h (+1 -1), constHandle.h (+1 -1), notset.h (+1 -1), sci_system.cc (+1 -1), sci_system.h (new 1), soloader.cc (+1 -1), soloader.h (new), sub.mk (+1 -1), testEndian.h.in (+1 -1)
allen 2017-04-18 21:09 Rev.: 56445

removed needless incude of time.h

0 lines of code changed in 1 file:

  • Core/Util: FileUtils.cc (-1)
allen 2017-04-13 16:24 Rev.: 56421

Removed Time.h and replaced with Timers.hpp

0 lines of code changed in 3 files:

  • Core/Util: Time.cc (del), Time.h (del), sub.mk (-1)
dav 2017-03-15 18:16 Rev.: 56334


Todd asked that the SCI_DEBUG name be treated in a case-insensitive manner...
So now you can do:

setenv SCI_DEBUG my_debug_stream:+
or
setenv SCI_DEBUG MY_DEBUG_STREAM:+
or
setenv SCI_DEBUG my_DEBUG_stream:+

and they will all work and refer to the same thing.

M Core/Util/DebugStream.h
M Core/Util/DebugStream.cc

- Fixed formatting, naming conventions, spacing, etc.

125 lines of code changed in 2 files:

  • Core/Util: DebugStream.cc (+65 -46), DebugStream.h (+60 -55)
dav 2017-02-26 18:03 Rev.: 56253


Continuation of commit r56249 - getting into the Core and the UCF now.

Mostly cosmetic changes - removing the actual hack (see Handle.h below) to
allow for better type safety using c++11 nullptr.

These changes have passed the local RT on Baja.

- The biggest update in this commit (the update to remove the c++11 warning hack) is that you will
no longer be able to compare a ProblemSpecP to 0 (you will need to compare to 'nullptr').

- White space, coding standards, indentation, remove tabs.
- Line up some variables to make them easier to read.
- Use of 80+ columns of text (we decided to allow this 10 years ago) and it makes reading longer lines of code on the screen easier.
- Use {} for if/else clauses even if they are only one line long.
- Please put "else" and "else if" on a new line. The added white space makes following the branching much easier.

M CCA/Components/Arches/BoundaryConditions/BoundaryFunctorHelper.cc
M CCA/Components/LoadBalancers/DynamicLoadBalancer.cc
M CCA/Components/LoadBalancers/LoadBalancerCommon.cc
M CCA/Components/LoadBalancers/ParticleLoadBalancer.cc
M CCA/Components/Schedulers/DynamicMPIScheduler.cc
M CCA/Components/Schedulers/MPIScheduler.cc
M CCA/Components/Schedulers/UnifiedScheduler.cc
M CCA/Ports/PIDXOutputContext.cc
M Core/GeometryPiece/GeometryPieceFactory.cc
M Core/Grid/BoundaryConditions/BCDataArray.cc
M Core/Grid/BoundaryConditions/BCDataArray.h

- Pass const strings as references instead of copying.

M Core/Grid/BoundaryConditions/BCUtils.cc
M Core/Grid/BoundaryConditions/BoundCondReader.cc

M Core/Grid/Level.h
M Core/Grid/Level.cc

- Pass const params as const.
- Removed m_patches variables as it isn't used anywhere.
- Very few real changes in this file, use diff -w.

M Core/Grid/Patch.h
M Core/Grid/Patch.cc

- Place .h one line functions on one line as it makes the viewing of the Class spec easier
(and this is the main purpose of the .h file.)
- Line up vars/ for easier reading.

M Core/Grid/Task.cc

M Core/Grid/Variables/ComputeSet.h

- Place .h one line functions on one line as it makes the viewing of the Class spec easier
(and this is the main purpose of the .h file.)

M Core/Grid/Variables/ParticleVariable.h
M Core/Grid/Variables/ParticleVariable_special.cc
M Core/Grid/Variables/Variable.cc

- Fix end comment on readPIDX()

M Core/Util/Handle.h

- Here is the hack that is being removed... The "==" operator was overloaded in order
to allow for comparison of pointers to 0. When this is removed, then (previous to these
commits) you would be spammed by warnings about ambiguous "==" operator. By removing this
operator and forcing the comparison to nullptr (as of c++11), type safety is increased.

19 lines of code changed in 1 file:

  • Core/Util: Handle.h (+19 -29)
Generated by StatSVN 0.7.0