[root]/Packages/Uintah/CCA/Components/ICE/CustomBCs
Author | Changes | Lines of Code | Lines per Change |
---|---|---|---|
Totals | 54 (100.0%) | 331 (100.0%) | 6.1 |
luitjens | 24 (44.4%) | 152 (45.9%) | 6.3 |
harman | 18 (33.3%) | 136 (41.1%) | 7.5 |
jas | 7 (13.0%) | 40 (12.1%) | 5.7 |
dav | 5 (9.3%) | 3 (0.9%) | 0.6 |
set default values for
setMicroSlipBcs = false
set_MMS_BCs = false
set_Sine_BCs = false
This will clean up valgrind report for ICE
0 lines of code changed in 2 files:
Added some more functionality to the getEdgeCellIterator function.
4 lines of code changed in 2 files:
changed:
patch::faceAxes() -> patch::getFaceAxes()
to be consistent with getFaceDirection()
19 lines of code changed in 5 files:
Fixes to allow Uintah to build using the PGI compiler:
M configure
M configure.ac
- Figure out size of 'long long' so that Endian.cc swapbytes() can be
set correctly... perhaps a bit of overkill, but...
- PGI compilers don't support -Wall, so don't use it.
- Better messages when determining dependency generation flag. Fix
grep for ":" as it sometimes is " :". See below (configVars.mk.in).
- pgf77 needs -lrt to link.
M configVars.mk.in
- ECHO should not be "echo -n" (no newline)... so named it more appropriately.
- Many compilers don't create dependency files (.d) with exactly "name.o : name.cc".
Then may use "name.o:name.cc". So don't use the ":" in the sed. This should
never cause a problem because of the "^".
- Added the dependency mode of: 'modify_and_move'. PGI compiler creates an invalid
.d file in the wrong place, so we have to fix it and move it.
- NOTE: the F77 dependency flag is currently (historically) just a copy of the CXX
flag... this has worked in the past and still works for everything but pgf77.
Soon (but not in this update) I will fix configure to do this correctly.
M StandAlone/regression/sub.mk
M Packages/Uintah/StandAlone/tools/compare_mms/sub.mk
M Packages/Uintah/StandAlone/tools/radiusMaker/sub.mk
- Need BLAS_LIBRARY to link... at least on Ranger using PGI.
- Please indent... it really does make it easier to read.
M Core/Malloc/Allocator.cc
Moved variable into the #if section that it is used in. Avoids compiler warning.
M Core/Util/Endian.cc
A Core/Util/testEndian.h.in
D Core/Util/Endian.h
- pgcc is requiring the swapbytes() for 'long long'... So add it
in. Since 'long long' size can be different on different machines,
use overkill method with configure figuring out size and setting it
for us.
- Moved Endian.h to testEndian.h.in to allow configure to modify it.
- Indented.
M Core/Util/sub.mk
M Packages/Uintah/Core/Grid/Variables/sub.mk
Untabified.
M Core/Util/Socket.cc
Fix compiler warning and possible 'random' error.
M Core/Math/MiscMath.cc
Fix PGI compiler issue.
M Packages/Uintah/CCA/Components/DataArchiver/DataArchiver.cc
M Packages/Uintah/CCA/Components/Schedulers/SchedulerCommon.cc
#include <time.h> is required for time functions.
M Packages/Uintah/CCA/Components/ICE/EOS/IdealGas.cc
M Packages/Uintah/CCA/Components/ICE/CustomBCs/sine.h
M Packages/Uintah/CCA/Components/ICE/CustomBCs/MMS_BCs.cc
M Packages/Uintah/CCA/Components/ICE/CustomBCs/microSlipBCs.cc
M Packages/Uintah/CCA/Components/ICE/BoundaryCond.cc
- Removed a bunch of definitions of "iter". (vector<IntVector>::const_iterator)...
probably a leftover from the iterator update a while back. In some cases,
renamed an interior (for loop) iterator from "iter" to "cIter" so that the
code would be a little more clear as to which iterator was being used
inside the inner for loop. Also, define some iterators in the for loop,
instead of above the loop. (for( vector::iterator iter...))
M Packages/Uintah/CCA/Components/ICE/AMRICE.h
M Packages/Uintah/Core/Grid/Variables/GridVariable.h
M Packages/Uintah/Core/Grid/Variables/GridVariableBase.h
Fix compiler warning about hidden parent class function.
M Packages/Uintah/CCA/Components/Arches/ExtraScalarSolver.h
Fix compiler warning about ineffectual use of a const return type. Eg:
const int doSomething() { return 1; }
doesn't mean anything... it doesn't make sense for the returned int to
be const. Should just be:
int doSomething() { return 1; }
M Packages/Uintah/CCA/Ports/SFC.h
Fix problem with nested comments. Don't use /* ... */ over many lines. Use #if 0.
M Packages/Uintah/StandAlone/tools/uda2nrrd/particles.cc
Comment about invalid code.
M Packages/Uintah/StandAlone/tools/puda/varsummary.cc
PGI compiler needs Min/Max defined.
M Packages/Uintah/StandAlone/tools/extractors/partextract.cc
#include <stdlib.h> for strtoll... Add hack to force (older (verion
7.1-2)) pgCC to allow strtoll.
M Packages/Uintah/Core/Grid/Patch.h
M Packages/Uintah/Core/Grid/AMR.h
Hack to remove PGI compiler warnings about unreachable code.
M Packages/Uintah/Core/Grid/Grid.h
Use white space... it is also your friend. Seriously (on a related
note ;) can someone tell me why they think "x=3;" is better than "x = 3;"?
M Packages/Uintah/Core/Grid/Variables/ReductionVariable_special.cc
Wow, this is an ugly file... Had to add some (templated) functions
that the PGI compiler was requiring.
M Packages/Uintah/Core/Grid/Variables/ComputeSet.h
Don't seem to need to #include the .cc file (for the templates) with
PGI anymore... at least not on Ranger using pgCC version 7.1-2.
M Packages/Uintah/Core/Grid/Variables/VarTypes.h
Needs the 'long long' var type.
M Packages/Uintah/Core/Grid/Variables/ComputeSet_special.cc
More use of white space, indentation, etc.
M Packages/Uintah/Core/DataArchive/DataArchive.cc
Added {} around what looks like a necessary block of code... strange
that this didn't cause hangs, etc in the code. Perhaps this section
of code isn't used that often? Hope the RT doesn't gripe
tomorrow... it's not my fault!
M Packages/Uintah/Core/Disclosure/TypeUtils.h
M Packages/Uintah/Core/Disclosure/TypeUtils.cc
Added 'long long' function. Organized the code a tad bit to make it
easier to see which functions (for which types) are defined.
M Packages/Uintah/testprograms/sub.mk
M Packages/Uintah/testprograms/PatchBVH/sub.mk
M Packages/Uintah/testprograms/TestFastMatrix/sub.mk
M Packages/Uintah/testprograms/BNRRegridder/sub.mk
M Packages/Uintah/testprograms/IteratorTest/sub.mk
Untabify. Clean up. Removed double definition of LIBS. Requires
BLAS_LIBRARY to link.
M Packages/Uintah/tools/BlasLapackTests/test_blas.c
Ranger's version of testcase... not sure I should have checked it
in... Probably need to have both with the #if separating them.
M Packages/Uintah/Dataflow/Modules/Selectors/ParticleFieldExtractor.h
Fix compiler warning about hidden function (update_progress).
M Packages/Uintah/Dataflow/Modules/Selectors/ParticleFieldExtractor.cc
Fix includes (better ordering). Fix (hack) PGI problem with finding atoll.
M Packages/Uintah/Dataflow/Modules/Selectors/FieldExtractor.h
More white space. Remove unused var. Move common code to above 'if'.
3 lines of code changed in 5 files:
Don't call reset() from begin() instead call reset when it is needed. Calling reset from begin could cause lots of unintended consequences.
11 lines of code changed in 7 files:
Use the new Iterator framework for assigning boundary conditions.
40 lines of code changed in 7 files:
Fixed some compiler warnings. The majority of them were unused variables. In the case of unused variables I deleted them if they wern't referenced to in comments. If they were referenced in comments I commented them out.
Other fixes included braketing ifs and parenthesizing boolean statements.
9 lines of code changed in 1 file:
Deleted function that reproduced Sutherland & Kennedy right hand rule mistake.
16 lines of code changed in 1 file:
Only compute the Li terms for ICE materials
10 lines of code changed in 1 file:
characteristic_source_terms()
fixed typo in Sutherland's paper.
11 lines of code changed in 1 file:
Only write to the datawarehouse the Li terms during the advection task.
2 lines of code changed in 1 file:
Added ability to save Li terms for the LODI BCs.
43 lines of code changed in 3 files:
New Patch Conversion:
getCellLow/HighIndex -> getExtraCellLow/HighIndex
getEdgeCellIterator() -> getEdgeCellIterator__New
getCellIterator() -> getCellIterator__New
8 lines of code changed in 1 file:
New Patch Conversion:
getFaceCellIterator() -> getFaceIterator__New()
27 lines of code changed in 3 files:
added comments and moved cullIntersection, nodePostion, and cellPosition
to the completed section.
updated getBox and getInteriorBox to the new interface, renamed them to
getExtraBox and getBox.
renamed neighborsLow to noNeighborsLow and neighborsHigh to
noNeighborsHigh. This follows the logic that 1 is true and 0 is false.
6 lines of code changed in 2 files:
Converted all but 1 instance of getBoundaryFaces to the new interface.
The remaining one produces different results when the boundary faces are
returned in a different order.
Converted all instances of getCornerCells over to the new interface.
41 lines of code changed in 3 files:
Rolled back changes in 40683, 40653, and 40651. These changes are
suspect to what is changing the answers.
This appears to fix the Models tests but does not fix the MPMICE tests.
26 lines of code changed in 3 files:
Changed the for loops to be on 1 line...
7 lines of code changed in 3 files:
The code is now using the new versions of getCornerCells and
getBoundaryFaces. If these pass regressions tests then the old code
will be removed and a couple vectors will be removed from the patch
class.
48 lines of code changed in 3 files: