[root]/Packages/Uintah/CCA/Components/Parent
Author | Changes | Lines of Code | Lines per Change |
---|---|---|---|
Totals | 15 (100.0%) | 63 (100.0%) | 4.2 |
dav | 6 (40.0%) | 55 (87.3%) | 9.1 |
guilkey | 5 (33.3%) | 7 (11.1%) | 1.4 |
jas | 1 (6.7%) | 1 (1.6%) | 1.0 |
luitjens | 2 (13.3%) | 0 (0.0%) | 0.0 |
harman | 1 (6.7%) | 0 (0.0%) | 0.0 |
Adding a new component. This is the beginnings of a discrete model
for angiogenesis. Still much work to be done.
6 lines of code changed in 4 files:
The Switcher component used to record the UDA name in the <input_file>
section (of the input.xml file):
<SimulationComponent>
...
<subcomponent>
...
<input_file>HTContainer_arches_mpmice.uda.006/input.xml.0</input_file>
</subcomponent>
...
</SimulationComponent>
This causes a problem when trying to restart an UDA if you run from a
directory not directly containing the UDA directory (or if the UDA was
renamed). I've updated the code to not record the UDA name (now it
just puts input.xml.#). I've also updated the code such that if it
sees an uda name (in the input.xml file), it removes it, and then it
adds in the UDA name as specified when sus was run.
M CCA/Components/Parent/Switcher.h
M CCA/Components/Parent/ComponentFactory.cc
Pass the uda name into the Switcher.
M CCA/Components/Parent/Switcher.cc
- Handle input_file name correctly (for both new and old UDAs).;
- Don't add the UDA name to the <input_file> tag in new UDAs.
- Formatting tweaks to make code more readable.
- Rename variable 'in' to 'input_file' so I could actually search through the file for it. ;)
M StandAlone/inputs/ups_spec.xml
Update the ups spec file for SimulationComponents. Note, the Switcher
component is still not correctly specified and should be updated by
someone who has worked on and knows it.
46 lines of code changed in 5 files:
Verify that MPI is in use when running arches... as arches needs petsc which needs mpi...
9 lines of code changed in 1 file:
Remove options for fmpmice.
1 lines of code changed in 1 file:
Fixed some compiler warnings. The majority of them were unused variables. In the case of unused variables I deleted them if they wern't referenced to in comments. If they were referenced in comments I commented them out.
Other fixes included braketing ifs and parenthesizing boolean statements.
0 lines of code changed in 1 file:
Removed some unused variables
0 lines of code changed in 1 file:
removed SimpleCFD and AMRSimpleCFD components
0 lines of code changed in 1 file:
Fix compiler warnings usually having to do with const char declarations.
1 lines of code changed in 1 file: