[root]/StandAlone
Benchmarks
(2 files, 227 lines)
tools
(2 files, 951 lines)
VisIt
(1 files, 826 lines)
compare_mms
(11 files, 1298 lines)
dumpfields
(28 files, 5148 lines)
extractors
(9 files, 5822 lines)
fsspeed
(2 files, 201 lines)
graphview
(8 files, 1635 lines)
makedot
(2 files, 239 lines)
mpi_test
(4 files, 956 lines)
pfs
(5 files, 1727 lines)
puda
(29 files, 4268 lines)
uda2vis
(4 files, 1872 lines)
Author | Changes | Lines of Code | Lines per Change |
---|---|---|---|
Totals | 48 (100.0%) | 330 (100.0%) | 6.8 |
allen | 20 (41.7%) | 266 (80.6%) | 13.3 |
dav | 4 (8.3%) | 28 (8.5%) | 7.0 |
harman | 3 (6.3%) | 13 (3.9%) | 4.3 |
ahumphrey | 6 (12.5%) | 13 (3.9%) | 2.1 |
jas | 12 (25.0%) | 8 (2.4%) | 0.6 |
jholmen | 1 (2.1%) | 2 (0.6%) | 2.0 |
guilkey | 2 (4.2%) | 0 (0.0%) | 0.0 |
removed duplicate output
0 lines of code changed in 2 files:
Broke the large libs into smaller libraries allowing of the removal the ModelFactory Component and moved all application code from core
0 lines of code changed in 1 file:
* Finish repairs and cleanup in Core/Malloc, specifically the Uintah default Allocator (when SCI_MALLOC is enabled). Remove legacy pthread code, recursive locks, etc. Use std::mutex, no need for recursive mutex.
* Remove sci_system, use std:system
* Remove all remaining pthread remnants (including THREAD_LIBRARY references). Only use and rely on std::thread. Should have never been mixing pthreads with std::thread. Can't bank on what the underlying thread impl is.
* Generate new configure script.
* Lastly, fix issue with MPM PetscSolver include. Now Uintah compiles without Petsc (e.g. --without-petsc), as it should be able to.
1 lines of code changed in 2 files:
Beginnings MALLOC_TRACE support removal, e.g. MALLOC_TRACE_TAG_SCOPE and other macros.
This library, though once useful, no longer works with Uintah and is not maintained, plus inextricably tied to SCI_MALLOC, which ultimately needs to go away.
0 lines of code changed in 1 file:
renamed ComponentFactory to Applicationfactory - moved model mgt from switcher to application
5 lines of code changed in 3 files:
added a SolverCommon class, made OnTheFlyAnalysis a first class UintahParallelComponent, added acess methods for component controll in UintahParallelComponent
49 lines of code changed in 1 file:
Cleanup of the Scheduler to use ports for all components
6 lines of code changed in 1 file:
Fix redundant calls to shutdown within Uintah::Allocator. When SCI_MALLOC was enabled, this was being called for all allocs, frees, etc, rewinding the file pointer and rewriting the stats_out file in some cases on the order of millions of times, appending redundnat info. The failing multibox_coal_rmcrt tests were not actually failing, but simply taking too long (because of this issue) and was killed because a max run time was exceeded.
Now we explicitly register shutdown function with std::atexit. This way the malloc_stats file, with accumulated data gets written once at very end. This is orders of magnitude faster than before and captures the full range of allocs, frees, occuring during entire simulation. I am convinced the previous code omitted ~5% of the total memory-related calls.
Removed USE_LENNY_HACK and LINUX_GETENV_HACK macros, and cleaned up Allocator significantly. It is now fairly readable. Need to purge MallocTrace remnants in the near future. This is additional confusing logic (interleaved with MALLOC_STATS code) for a library that no longer works with Uintah.
0 lines of code changed in 1 file:
Fix failing multibox_rmcrt_coal tests.
Faulty logic in the use of USE_LENNY_HACK macro was causing shutdown() to be called an inordinate amounts of times, consequently having to unnecessarily rifle through all the MALLOC_STATS bookkeeping each time.
Please someone tell me that Uintah no longer needs things like USE_LENNY_HACK and LINUX_GETENV_HACK.....
1 lines of code changed in 1 file:
added app tot eh load balancer
2 lines of code changed in 1 file:
Add ability to compare ParticleVariable<IntVector>
0 lines of code changed in 2 files:
changed/removed PostProcessUda calls
2 lines of code changed in 1 file:
Guard the DataArchiver DebugStream (check if dbg.active()). This is causing issues when not active on mira. DebugStreams need to go away in favor of much simpler Dout, as DebugStreams unnecessarily inherit from the standard library (std::ostream) and are unduley compicated for basic debug output.
Also cleaned up poor whitespace, linebreaks and indentation, other formatting. Seems like someone went through the infrastructure with a faulty code formatter previously...
11 lines of code changed in 1 file:
Global:
- Renamed the component and variables associated with reduceUda -> PostProcessUda
PostProcessUda.cc/h:
- cleaned out testing code
- added a common class
11 lines of code changed in 1 file:
removed the delta T label from the shared state and began removing the shared state where possible
4 lines of code changed in 2 files:
Fixed so the model maker is passed down correctly
32 lines of code changed in 1 file:
additional changes related to the Application Common
71 lines of code changed in 1 file:
* Added build system support for Kokkos.
* Added /src/include/sci_defs/kokkos_testdefs.h.in.
This commit allows --with-kokkos=DIR to be used to point to a Kokkos installation instead of CXXFLAGS and LDFLAGS.
Note, files using #define UINTAH_ENABLE_KOKKOS must now add #include <sci_defs/kokkos_defs.h> to manage this macro.
2 lines of code changed in 1 file:
update to move to a application common class and remove the shared state
84 lines of code changed in 2 files:
More descriptive exception message, added level index.
1 lines of code changed in 1 file:
Updated exception message. Output the timestep instead of the looping index.
1 lines of code changed in 1 file:
to to record vars changes with the insitu I added an output and restart problem spec restart to the archiver. As a side affect I compartmentalized the setup in the sim controller
1 lines of code changed in 1 file:
M configure
M configure.ac
- Check to make sure the user has specified the use of MPI. When configuring, the user must now
explicitly either specify --with-mpi=dir (or --with-mpi-include/lib), or use --with-mpi=built-in.
- Add in compiler spam reduction flag for Intel compiler remarks.
M StandAlone/sus.cc
- Cosmetic: Add in a code comment.
1 lines of code changed in 1 file:
Update copyright.
8 lines of code changed in 12 files:
removed needless incude of time.h
0 lines of code changed in 1 file:
removed Time.h
0 lines of code changed in 1 file:
Removed Time.h and replaced with Timers.hpp
10 lines of code changed in 1 file:
More (mostly cosmetic-ish) code cleanups.
- Added some white space to make for easier reading of code.
- Swatted some endls.
M CCA/Components/DataArchiver/DataArchiver.cc
- outputPS() function didn't do anything so removing it.
M CCA/Components/Schedulers/DetailedTasks.h
M CCA/Components/Schedulers/DetailedTasks.cc
- Put one line functions in .h files on same line to make the spec easier to read by the user.
- Mark class variables with "d_" (matching the few that were already done that way in this file) in order
to be able to know a class variable by sight when I see it in the code. (eg: d_task, d_patches, etc).
M CCA/Components/Schedulers/OnDemandDataWarehouse.h
M CCA/Components/Schedulers/OnDemandDataWarehouse.cc
- Updated a few constructor parameters with const (as they don't change in the function).
M CCA/Components/Schedulers/TaskGraph.cc
- Handle new Task class variables names (from DetailedTask above) - eg: 'd_task' instead of 'task'.
- Alan, I'm pretty sure I merged this right, but there were a lot of conflicts... if I messed up
something from your commit, I apologize - just let me know and I'll look at it in more detail and fix
it. -Dav
M CCA/Components/SimulationController/AMRSimulationController.cc
- Alan, same commit as previous file.
- Run through "diff -w" to more easily parse changes.
- Many of the DebugStreams are local to this file, so make them 'static'.
- Untabify / white space.
- Use "using namespace std" as we use this everywhere else.
M CCA/Ports/SimulationInterface.h
M CCA/Ports/SimulationInterface.cc
- White space / alignment for readability.
- Removed outputPS() interface as it isn't used by anyone.
- Moved the empty preGridProblemSetup() into the .cc file... can't remember why I did this exactly,
but most likely I was debugging in there and didn't want to have to recompile all of Uintah
every time. Also might have wanted to make it pure virtual (I think all the stubs in this interface
probably should be pure virtual), but I think this was non-trivial to do.
- Untabify.
- Use {} with if's.
M StandAlone/inputs/ARCHES/RMCRT/rmcrt_bm1_DO.ups
M StandAlone/inputs/ARCHES/RMCRT/rmcrt_bm1_ML.ups
M StandAlone/inputs/Examples/RMCRT_+Domain_ML.ups
M StandAlone/inputs/Examples/RMCRT_ML.ups
M StandAlone/inputs/Examples/RMCRT_bm1_DO.ups
M StandAlone/inputs/ICE/BW_reflect_AMR.ups
M StandAlone/inputs/ICE/advect2matAMR.ups
M StandAlone/inputs/ICE/advectScalarAMR.ups
M StandAlone/inputs/ICE/explosion.ups
M StandAlone/inputs/ICE/hotBlob_AMR.ups
M StandAlone/inputs/ICE/impAdvectAMR.ups
M StandAlone/inputs/ICE/impHotBlobAMR.ups
M StandAlone/inputs/ICE/impVorticesAMR.ups
M StandAlone/inputs/ICE/programBurnAMR.ups
M StandAlone/inputs/ICE/riemann2D_AMR.ups
M StandAlone/inputs/ICE/riemann_AMR.ups
M StandAlone/inputs/IS/ArchesHeatUpExplosion/Explode_IS.ups
M StandAlone/inputs/IS/ArchesHeatUpExplosion/HTContainer_arches_mpmice.ups
M StandAlone/inputs/IS/ArchesHeatUpExplosion/HTContainer_heatup.ups
M StandAlone/inputs/IS/ArchesHeatUpExplosion/JP8_fire.ups
M StandAlone/inputs/IS/explodingContainers_AMR.ups
M StandAlone/inputs/IS/hollow_AMR.ups
M StandAlone/inputs/IS/solid_AMR.ups
M StandAlone/inputs/MPM/advect_2L_3D_edges.ups
M StandAlone/inputs/MPM/advect_2L_3D_slabs.ups
M StandAlone/inputs/MPM/advect_3L_1D.ups
M StandAlone/inputs/MPM/advect_3L_3D.ups
M StandAlone/inputs/MPM/disks.ups
M StandAlone/inputs/MPM/riemannMPM_ML.ups
M StandAlone/inputs/MPMICE/advect_2L_MI.ups
M StandAlone/inputs/MPMICE/explode2D_amr.ups
M StandAlone/inputs/Models/scalarJet_AMR.ups
M StandAlone/inputs/Scaling/ranger/large+.ups
M StandAlone/inputs/Scaling/ranger/large.ups
M StandAlone/inputs/Scaling/ranger/med+.ups
M StandAlone/inputs/Scaling/ranger/med.ups
M StandAlone/inputs/Scaling/ranger/small.ups
M StandAlone/inputs/UCF/LBwoRegrid.ups
M StandAlone/inputs/UCF/Switcher/ex4_phase2.ups
M StandAlone/inputs/UCF/Switcher/ex4_phases1_3.ups
M StandAlone/inputs/UCF/Switcher/switchExample4.ups
M StandAlone/inputs/Wasatch/BasicScalarTransportEq_2L.ups
- Changed the way AMR is turned on. Instead of a standalone <doAMR> tag, I added
doAMR to the <Grid> tag. I'm not quite sure why we had <doAMR> in the first place,
as either associating it with the <Grid> (like I have) or just using the <AMR>
section itself seems to make more sense. Thoughts?
- Untabified, indented some of these files too. Use "diff -w" on them.
M StandAlone/inputs/UPS_SPEC/ups_spec.xml
- Added a BOOLEAN data type for data in the UPS file (in addition to DOUBLE, STRING, VECTOR, etc).
When fully implemented, this can help with type safety and validating UPS files as they are
parsed.
- Removed <doAMR> and added doAMR="true" to the <Grid>.
- Only allow PIDX and UDA as possible DataArchive formats (no reason to allow all permutations
of capitalization).
- walltimeStart and walltimeIntervalHorus are integers (as used in the code), so specify them as such.
- added <Grid saveToDisk="true">. But not fully implemented yet.
M StandAlone/sus.cc
- Can't run AMR and reduce_uda at the same time.
- Parse the new "doAMR" from .ups correctly.
M StandAlone/slb.cc
M StandAlone/tools/compare_mms/compare_mms.cc
M StandAlone/tools/graphview/GV_TaskGraph.cc
M StandAlone/tools/pfs/pfs.cc
M StandAlone/tools/pfs/pfs2.cc
M StandAlone/tools/pfs/rawToUniqueGrains.cc
- Make code more readable, follow a few more coding standards.
22 lines of code changed in 2 files:
Continuation of commit r56249 - fixes to get the Mac (pedantic compiler) back to working.
Forcing the comparison of pointers to nullptr instead of 0 to help with type safety.
A few cosmetic fixes including some of: Using 80+ columns, coding standards, if{}, indentation.
M CCA/Components/MPM/ReactionDiffusion/DiffusionModels/NonLinearDiff1.cc
M CCA/Components/Wasatch/ReductionHelper.cc
M CCA/Components/Wasatch/Properties.cc
M CCA/Components/Wasatch/FieldClippingTools.h
M CCA/Components/Wasatch/Wasatch.cc
M CCA/Components/Wasatch/ParseTools.cc
M CCA/Components/Wasatch/Expressions/EmbeddedGeometry/EmbeddedGeometryHelper.cc
M CCA/Components/Wasatch/WasatchParticlesHelper.cc
M CCA/Components/DataArchiver/DataArchiver.cc
M CCA/Components/Schedulers/DetailedTasks.cc
M CCA/Components/Schedulers/SchedulerCommon.cc
M Core/Grid/Grid.cc
M Core/DataArchive/DataArchive.cc
M StandAlone/tools/pfs/rawToUniqueGrains.cc
M StandAlone/tools/pfs/pfs.cc
M StandAlone/tools/pfs/pfs2.cc
M StandAlone/tools/fsspeed/fsspeed.cc
M StandAlone/tools/graphview/GV_TaskGraph.cc
M StandAlone/tools/compare_mms/compare_mms.cc
M StandAlone/slb.cc
5 lines of code changed in 1 file: