[root]/StandAlone/tools/compare_mms
Author | Changes | Lines of Code | Lines per Change |
---|---|---|---|
Totals | 25 (100.0%) | 129 (100.0%) | 5.1 |
dav | 2 (8.0%) | 117 (90.7%) | 58.5 |
jas | 21 (84.0%) | 11 (8.5%) | 0.5 |
ahumphrey | 2 (8.0%) | 1 (0.8%) | 0.5 |
* Finish repairs and cleanup in Core/Malloc, specifically the Uintah default Allocator (when SCI_MALLOC is enabled). Remove legacy pthread code, recursive locks, etc. Use std::mutex, no need for recursive mutex.
* Remove sci_system, use std:system
* Remove all remaining pthread remnants (including THREAD_LIBRARY references). Only use and rely on std::thread. Should have never been mixing pthreads with std::thread. Can't bank on what the underlying thread impl is.
* Generate new configure script.
* Lastly, fix issue with MPM PetscSolver include. Now Uintah compiles without Petsc (e.g. --without-petsc), as it should be able to.
1 lines of code changed in 2 files:
Update copyright.
11 lines of code changed in 21 files:
More (mostly cosmetic-ish) code cleanups.
- Added some white space to make for easier reading of code.
- Swatted some endls.
M CCA/Components/DataArchiver/DataArchiver.cc
- outputPS() function didn't do anything so removing it.
M CCA/Components/Schedulers/DetailedTasks.h
M CCA/Components/Schedulers/DetailedTasks.cc
- Put one line functions in .h files on same line to make the spec easier to read by the user.
- Mark class variables with "d_" (matching the few that were already done that way in this file) in order
to be able to know a class variable by sight when I see it in the code. (eg: d_task, d_patches, etc).
M CCA/Components/Schedulers/OnDemandDataWarehouse.h
M CCA/Components/Schedulers/OnDemandDataWarehouse.cc
- Updated a few constructor parameters with const (as they don't change in the function).
M CCA/Components/Schedulers/TaskGraph.cc
- Handle new Task class variables names (from DetailedTask above) - eg: 'd_task' instead of 'task'.
- Alan, I'm pretty sure I merged this right, but there were a lot of conflicts... if I messed up
something from your commit, I apologize - just let me know and I'll look at it in more detail and fix
it. -Dav
M CCA/Components/SimulationController/AMRSimulationController.cc
- Alan, same commit as previous file.
- Run through "diff -w" to more easily parse changes.
- Many of the DebugStreams are local to this file, so make them 'static'.
- Untabify / white space.
- Use "using namespace std" as we use this everywhere else.
M CCA/Ports/SimulationInterface.h
M CCA/Ports/SimulationInterface.cc
- White space / alignment for readability.
- Removed outputPS() interface as it isn't used by anyone.
- Moved the empty preGridProblemSetup() into the .cc file... can't remember why I did this exactly,
but most likely I was debugging in there and didn't want to have to recompile all of Uintah
every time. Also might have wanted to make it pure virtual (I think all the stubs in this interface
probably should be pure virtual), but I think this was non-trivial to do.
- Untabify.
- Use {} with if's.
M StandAlone/inputs/ARCHES/RMCRT/rmcrt_bm1_DO.ups
M StandAlone/inputs/ARCHES/RMCRT/rmcrt_bm1_ML.ups
M StandAlone/inputs/Examples/RMCRT_+Domain_ML.ups
M StandAlone/inputs/Examples/RMCRT_ML.ups
M StandAlone/inputs/Examples/RMCRT_bm1_DO.ups
M StandAlone/inputs/ICE/BW_reflect_AMR.ups
M StandAlone/inputs/ICE/advect2matAMR.ups
M StandAlone/inputs/ICE/advectScalarAMR.ups
M StandAlone/inputs/ICE/explosion.ups
M StandAlone/inputs/ICE/hotBlob_AMR.ups
M StandAlone/inputs/ICE/impAdvectAMR.ups
M StandAlone/inputs/ICE/impHotBlobAMR.ups
M StandAlone/inputs/ICE/impVorticesAMR.ups
M StandAlone/inputs/ICE/programBurnAMR.ups
M StandAlone/inputs/ICE/riemann2D_AMR.ups
M StandAlone/inputs/ICE/riemann_AMR.ups
M StandAlone/inputs/IS/ArchesHeatUpExplosion/Explode_IS.ups
M StandAlone/inputs/IS/ArchesHeatUpExplosion/HTContainer_arches_mpmice.ups
M StandAlone/inputs/IS/ArchesHeatUpExplosion/HTContainer_heatup.ups
M StandAlone/inputs/IS/ArchesHeatUpExplosion/JP8_fire.ups
M StandAlone/inputs/IS/explodingContainers_AMR.ups
M StandAlone/inputs/IS/hollow_AMR.ups
M StandAlone/inputs/IS/solid_AMR.ups
M StandAlone/inputs/MPM/advect_2L_3D_edges.ups
M StandAlone/inputs/MPM/advect_2L_3D_slabs.ups
M StandAlone/inputs/MPM/advect_3L_1D.ups
M StandAlone/inputs/MPM/advect_3L_3D.ups
M StandAlone/inputs/MPM/disks.ups
M StandAlone/inputs/MPM/riemannMPM_ML.ups
M StandAlone/inputs/MPMICE/advect_2L_MI.ups
M StandAlone/inputs/MPMICE/explode2D_amr.ups
M StandAlone/inputs/Models/scalarJet_AMR.ups
M StandAlone/inputs/Scaling/ranger/large+.ups
M StandAlone/inputs/Scaling/ranger/large.ups
M StandAlone/inputs/Scaling/ranger/med+.ups
M StandAlone/inputs/Scaling/ranger/med.ups
M StandAlone/inputs/Scaling/ranger/small.ups
M StandAlone/inputs/UCF/LBwoRegrid.ups
M StandAlone/inputs/UCF/Switcher/ex4_phase2.ups
M StandAlone/inputs/UCF/Switcher/ex4_phases1_3.ups
M StandAlone/inputs/UCF/Switcher/switchExample4.ups
M StandAlone/inputs/Wasatch/BasicScalarTransportEq_2L.ups
- Changed the way AMR is turned on. Instead of a standalone <doAMR> tag, I added
doAMR to the <Grid> tag. I'm not quite sure why we had <doAMR> in the first place,
as either associating it with the <Grid> (like I have) or just using the <AMR>
section itself seems to make more sense. Thoughts?
- Untabified, indented some of these files too. Use "diff -w" on them.
M StandAlone/inputs/UPS_SPEC/ups_spec.xml
- Added a BOOLEAN data type for data in the UPS file (in addition to DOUBLE, STRING, VECTOR, etc).
When fully implemented, this can help with type safety and validating UPS files as they are
parsed.
- Removed <doAMR> and added doAMR="true" to the <Grid>.
- Only allow PIDX and UDA as possible DataArchive formats (no reason to allow all permutations
of capitalization).
- walltimeStart and walltimeIntervalHorus are integers (as used in the code), so specify them as such.
- added <Grid saveToDisk="true">. But not fully implemented yet.
M StandAlone/sus.cc
- Can't run AMR and reduce_uda at the same time.
- Parse the new "doAMR" from .ups correctly.
M StandAlone/slb.cc
M StandAlone/tools/compare_mms/compare_mms.cc
M StandAlone/tools/graphview/GV_TaskGraph.cc
M StandAlone/tools/pfs/pfs.cc
M StandAlone/tools/pfs/pfs2.cc
M StandAlone/tools/pfs/rawToUniqueGrains.cc
- Make code more readable, follow a few more coding standards.
80 lines of code changed in 1 file:
Continuation of commit r56249 - fixes to get the Mac (pedantic compiler) back to working.
Forcing the comparison of pointers to nullptr instead of 0 to help with type safety.
A few cosmetic fixes including some of: Using 80+ columns, coding standards, if{}, indentation.
M CCA/Components/MPM/ReactionDiffusion/DiffusionModels/NonLinearDiff1.cc
M CCA/Components/Wasatch/ReductionHelper.cc
M CCA/Components/Wasatch/Properties.cc
M CCA/Components/Wasatch/FieldClippingTools.h
M CCA/Components/Wasatch/Wasatch.cc
M CCA/Components/Wasatch/ParseTools.cc
M CCA/Components/Wasatch/Expressions/EmbeddedGeometry/EmbeddedGeometryHelper.cc
M CCA/Components/Wasatch/WasatchParticlesHelper.cc
M CCA/Components/DataArchiver/DataArchiver.cc
M CCA/Components/Schedulers/DetailedTasks.cc
M CCA/Components/Schedulers/SchedulerCommon.cc
M Core/Grid/Grid.cc
M Core/DataArchive/DataArchive.cc
M StandAlone/tools/pfs/rawToUniqueGrains.cc
M StandAlone/tools/pfs/pfs.cc
M StandAlone/tools/pfs/pfs2.cc
M StandAlone/tools/fsspeed/fsspeed.cc
M StandAlone/tools/graphview/GV_TaskGraph.cc
M StandAlone/tools/compare_mms/compare_mms.cc
M StandAlone/slb.cc
37 lines of code changed in 1 file: