[root]/CCA/Components/SimulationController
Author | Changes | Lines of Code | Lines per Change |
---|---|---|---|
Totals | 106 (100.0%) | 2610 (100.0%) | 24.6 |
allen | 73 (68.9%) | 1292 (49.5%) | 17.6 |
mcconnell | 6 (5.7%) | 933 (35.7%) | 155.5 |
ahumphrey | 18 (17.0%) | 359 (13.8%) | 19.9 |
dav | 3 (2.8%) | 20 (0.8%) | 6.6 |
jas | 6 (5.7%) | 6 (0.2%) | 1.0 |
minor interface change as vars do not need to be passed, also minor name change so to associate it with a recomute
0 lines of code changed in 2 files:
Generalize the concept of a task graph having tasks with "distal" halo requirements, meaning the number, order, and appearance of TGs with distal requires is arbitrary. This is a much more robust way to determine distal neighborhood creation, etc. Prior to this, the code was quite brittle, depending on the distal TG being last in the order.
2 lines of code changed in 1 file:
added check for only dumping with non zero stat values
0 lines of code changed in 2 files:
added support to handle sole vars similar to reduction vars. Both being global vars
6 lines of code changed in 1 file:
removed the time from the getTaskGraphIndex interface and changed the name
8 lines of code changed in 1 file:
Cleanup under the hood while working. Mainly readbility improvements and addding {} for single-line conditionals, etc.
101 lines of code changed in 1 file:
added the optional ability to get min and std dev stats
33 lines of code changed in 1 file:
minor change to use the reduction var when scheduled
9 lines of code changed in 1 file:
added comment and refactored the in situ terminate
9 lines of code changed in 2 files:
removed reduction for individual stats
2 lines of code changed in 1 file:
name clean up
13 lines of code changed in 1 file:
removed the intial value and set the initial count to zero
37 lines of code changed in 1 file:
stat clean up
85 lines of code changed in 1 file:
made the scrubbing of saved vars optional
6 lines of code changed in 1 file:
removed the start sim time and sim to wall time stats. Added friend class to the app. interface
46 lines of code changed in 1 file:
removed the recompile flag from app common and restructured the calls
5 lines of code changed in 1 file:
separated the runtime and application stat reporting
106 lines of code changed in 1 file:
Simulation controllers: DebugStream --> Dout
Some misc cleanup and output formatting.
76 lines of code changed in 1 file:
Repair Gpertools support.
1 lines of code changed in 1 file:
Remove PAPI support.
This direct support is no longer necessary, as almost all profiling tools sit on top of PAPI. No sense in us maintaining code that's avialble through professional tools.
148 lines of code changed in 8 files:
refined the application reduction var class
3 lines of code changed in 1 file:
removed the delta flag
4 lines of code changed in 1 file:
added debug flag to report the current delta t instead of the next except for the inital time step
16 lines of code changed in 1 file:
remaned PostProcess files to PostProcessUda to match class name within
1 lines of code changed in 1 file:
cleaned up the DOUT macros, consistent naming of timethresholds, added option to validate next delta before the reduction
4 lines of code changed in 2 files:
deprecated the SimulationTime class and moved it to be fully contained in the ApplicationCommon
3 lines of code changed in 2 files:
changed the delta T reduction to be last and modified the var name to match the xml name
2 lines of code changed in 1 file:
added restart file and time step to the output spew
4 lines of code changed in 1 file:
removal of shared state and introduction of a material manager
10 lines of code changed in 2 files:
added a managing class for application reduction variables
7 lines of code changed in 2 files:
made the recompute and abort reduction vars
15 lines of code changed in 2 files:
change from restart to recompute time step so to differentiate from restarting a time step from a checkpoint
9 lines of code changed in 1 file:
renamed the methods to differentiate between rank and node values
26 lines of code changed in 1 file:
added additional time info
37 lines of code changed in 1 file:
reworked the wall time usage to minimize the cost of getting it
69 lines of code changed in 2 files:
fixed typo
1 lines of code changed in 1 file:
changed the reports so it can be less frequent
66 lines of code changed in 2 files:
This fixes an issue with (older/non-compliant?) file systems with respect to deleting directories.
For many years We had a 'hack' in place for AIX file systems to use 'stat' instead of the cheaper
"file->d_type" check. It turns out that we should (have been) use the hack anytime that file->d_type
is DT_UNKNOWN, not just under AIX. This should fix the problem that some people were seeing on some
file systems where (checkpoint) diretories were not being deleted when they should have been.
M CCA/Components/DataArchiver/DataArchiver.h
M CCA/Components/DataArchiver/DataArchiver.cc
- Const'ify a number of method params that are not changed in the functions (and thus should be declared const).
- Add some white space for readability.
- Actually print out warning messages when old checkpoint directories fail to be deleted.
M CCA/Components/Schedulers/OnDemandDataWarehouse.cc
M CCA/Components/SimulationController/SimulationController.cc
- Purely cosmetic: Add some white space for readability.
M CCA/Ports/Output.h
- Match updated interface (ie, use of const) for DataArchiver.
- Add some white space for readability.
M Core/OS/Dir.h
M Core/OS/Dir.cc
- Add 'const' due to addition of const above.
- Add some white space for readability.
- Fix the check that we use to determine if a 'file' is a directory (see above).
M Core/OS/Dir_boost.cc
- Add const, white space, and {} for if statement.
1 lines of code changed in 1 file:
added a flag to the app to know it is restarting
4 lines of code changed in 2 files:
This commit brings the PIDX data I/O branch (named: pidx_xml) back into the trunk.
All PIDX data I/O is, by default, turned off. To use PIDX you have to configure
against the PIDX library (either installing manually and pointing at it, or using
the --with-pidx flag (not 100% certain that this works at the moment)), and you must
set <DataArchiver type="PIDX"> (as opposed to the default which is type="UDA") in
the .ups input file.
Other caveats:
- Particles are not (currently?) supported in PIDX so any simulation that has a
particle data type will fail (most will print an error that PIDX does not
support them, but it seems some just die).
- Simulations that have overlapping patches (this may just be AMR type
sims) (eg: multibox_rmcrt_coal_1L) can save (slightly different) results.
In the multibox_rmcrt_coal_1L, we saw (only) a handful of differences like this:
((A 1 vs a 0 in a couple of locations) Also note that the UDA itself compared
successfully, but the checkpoint underneath it did not...)
DIFFERENCE [int 36, 5, 0] Time: 0.0003106658 Level: 0 Patch1: 0 Patch2: 0 Material: 0 Variable: areaFractionFX
multibox_RMCRT_coal_1L.uda/checkpoints goldStandard/.../multibox_RMCRT_coal_1L.uda/checkpoints
1 0
- "#if HAVE_PIDX" is used inconsistently through a number of files. Some PIDX stuff is #if'd out, while other code
is left in and compiles, it is just not used.
- There are a lot of cleanups that can and should take place wrt the PIDX integration.
While the code passes all the local RT tests (with the exception of particle tests),
I don't believe it has been run at large scale (though it should work) on a BGQ or Quartz@llnl.
Summary of changes: (Note, see pidx_xml branch commits if you want more information.)
M CCA/Ports/ApplicationInterface.h
M CCA/Components/Application/ApplicationCommon.h
- Added the ability to record (and retrieve) the number for the last regrid time step.
M CCA/Components/DataArchiver/DataArchiver.h
M CCA/Components/DataArchiver/DataArchiver.cc
- When saving as PIDX, only create/output timestep.xml on the initial (I/O) time step that occurs after the regrid.
- Fixes that allow PIDX to save correctly (and efficiently) in parallel. If you are ever trying
to trace this back, read the comments from the commit logs for the "pidx_xml" branch.
- Remove createPIDX_dirs() as it was commented out and Sid tells me that PIDX creats its own dirs and we don't need this.
- Lot of white space fixes.
M CCA/Components/Examples/RMCRT_Test.cc
M CCA/Components/PostProcessUda/PostProcess.cc
- The DataArchive (DA) queryVariables() function now also returns the number of materials for each variable.
- "else" and "else if" should be on a separate line to make it easier to read.
M CCA/Components/Models/Radiation/RMCRT/RayGPU.cc
- Differentiate the output between the GPU and non-GPU reports so the viewer knows explicitly whether the GPU code was run.
M CCA/Components/Schedulers/OnDemandDataWarehouse.h
M CCA/Components/Schedulers/OnDemandDataWarehouse.cc
- Cosmetics: Line up variables, use more than 80 chars per line, white space.
Add in comments denoting default param values.
M CCA/Components/Schedulers/SchedulerCommon.cc
- Cosmetics.
M CCA/Components/SimulationController/AMRSimulationController.cc
- Cosmetics: Use more white space, 80+ chars per line for better readability, etc.
M CCA/Ports/PIDXOutputContext.h
- const'ify some params.
- checkReturnCode() is a static function so mark it so.
M CCA/Ports/PIDXOutputContext.cc
- White spacee. Code alignment for readability.
M Core/DataArchive/DataArchive.h
M Core/DataArchive/DataArchive.cc
- Add in PIDX functions. Note, queryPIDXSerial() is used (currently) by standalone codes (eg: puda).
Its purpose is to wrap the setupQueryPIDX()/queryPIDX() calls that have been added to
allow PIDX to truly run in parallel. At some point it would be good to update puda/compare_uda/etc
to run in parallel...
- See previous comments from PIDX branch for more details on the PIDX communicators that are necessary
to transfer data as some data does not live on all cores and thus can't use the golbal comm.
- Rename a few functions (queryAndSetParticlePositionName()) to be more accurate as to what they do.
- There are still a number of hacks in this code that need to be addressed (eg: var_materials map).
M Core/Geometry/IntVector.h
- Mostly cosmetics...
White space for readability.
Place 1-line functions in .h on one line to make it easier to see all provided functions.
M Core/Grid/Grid.cc
- White space, variable alignment for readability.
M Core/Grid/Level.h
M Core/Grid/Level.cc
- White space, coding standard (return type on its own line).
- Fix logic error in computeVariableExtents() that did not handle periodic boundaries correctly.
This fix was suggested as probably the correct way to do it by Todd... seems to pass tests and did fix
the issue (PIDX saving a particular something or other) that led me to it.
M Core/Grid/Patch.cc
- Place "else" on its own line for readability.
M Core/Grid/Variables/GridVariable.h
- Added emitPIDX().
- Opening "{" for functions in .h files goes on same line.
M Core/Grid/Variables/GridVariableBase.h
M Core/Grid/Variables/GridVariableBase.cc
- Organize #includes.
- White space, line up vars, etc for better readability.
- Return type on its own line.
M Core/Grid/Variables/ParticleData.h
- #include ParticleSubset.h for particleIndex.
M Core/Grid/Variables/ParticleSubset.h
- Cosmetic white space.
M Core/Grid/Variables/ParticleVariable.h
- White space, variable line up, etc.
- Added emitPIDX() function for particles. Note, particles do not fully work yet (on PIDX side).
And thus, this function hasn't really been tested.
M Core/Grid/Variables/ParticleVariableBase.h
M Core/Grid/Variables/ParticleVariableBase.cc
M Core/Grid/Variables/PerPatchBase.h
M Core/Grid/Variables/PerPatchBase.cc
M Core/Grid/Variables/ReductionVariableBase.h
M Core/Grid/Variables/ReductionVariableBase.cc
- Cosmetic white space. Coding standards. Etc.
M Core/Grid/Variables/Variable.h
M Core/Grid/Variables/Variable.cc
- Organize #includes.
- Use "const" on params that are const.
- Cosmetic white space, etc.
M Core/Grid/Variables/VarnameMatlPatch.h
- Pass non-changing strings by const reference (instead of copying them).
- White space for readability.
M Core/ProblemSpec/ProblemSpec.cc
- Line up vars, white space.
M R_Tester/helpers/compare_dat_files.pl
- Strip "/" from end of uda names.
- Clean up output to make it more readable (Todd I hope this doesn't break some of your scripts...)
M R_Tester/helpers/compare_dats
- White space.
M R_Tester/helpers/runSusTests.py
- Fix typo.
M StandAlone/compare_uda.cc
- White space.
- Line up vars.
- Coding standard.
- Line up case statement for better readability.
- 0 => nullptr
- query() now returns if the var was found (because PIDX has a list of all variables the simulation starts with
and the vars may not actually exist in the UDA.
- var => var_name (as it is actually the name, and not the var).
- Use 80+ columns.
M StandAlone/partvarRange.cco
M StandAlone/selectpart.cc
M StandAlone/tools/compute_Lnorm_udas.cc
M StandAlone/tools/dumpfields/dumpfields.cc
M StandAlone/tools/extractors/extractF.cc
M StandAlone/tools/extractors/extractS.cc
M StandAlone/tools/extractors/extractV.cc
M StandAlone/tools/extractors/faceextract.cc
M StandAlone/tools/extractors/lineextract.cc
M StandAlone/tools/extractors/partextract.cc
M StandAlone/tools/extractors/particle2tiff.cc
M StandAlone/tools/extractors/timeextract.cc
M StandAlone/tools/puda/AA_MMS.cc
M StandAlone/tools/puda/ER_MMS.cc
M StandAlone/tools/puda/GV_MMS.cc
M StandAlone/tools/puda/ICE_momentum.cc
M StandAlone/tools/puda/PIC.cc
M StandAlone/tools/puda/POL.cc
M StandAlone/tools/puda/asci.cc
M StandAlone/tools/puda/jacquie.cc
M StandAlone/tools/puda/jim1.cc
M StandAlone/tools/puda/jim2.cc
M StandAlone/tools/puda/jim3.cc
M StandAlone/tools/puda/pressure.cc
M StandAlone/tools/puda/puda.cc
M VisIt/interfaces/archiveInterface.cc
- queryVariables() now returns number of materials.
M StandAlone/tools/puda/varsummary.h
M StandAlone/tools/puda/varsummary.cc
- Swat some evil endls.
M build_scripts/build_pidx.sh
- FYI... Not sure if changing PIDX_TAG to "master" actually works...
M buildbot_try.sh
- Added a number of comments about use of this script.
- Fixed some typos.
- Spread command to multiple lines for readability.
16 lines of code changed in 1 file:
(26 more)