Directory CCA/Components/ICE/

Total Files:
19
Deleted Files:
0
Lines of Code:
16479

[root]/CCA/Components/ICE
                directory in repo Advection (12 files, 2880 lines)
                directory in repo CustomBCs (15 files, 5828 lines)
                directory in repo EOS (29 files, 4072 lines)
                directory in repo PressureSolve (0 files, 0 lines)
                    directory in repo HypreStandAlone (33 files, 5772 lines)
                directory in repo SpecificHeatModel (13 files, 1078 lines)
                directory in repo TurbulenceModel (9 files, 1348 lines)
                directory in repo WallShearStressModel (9 files, 992 lines)

Lines of Code

CCA/Components/ICE/ Lines of Code

Developers

Author Changes Lines of Code Lines per Change
Totals 72 (100.0%) 529 (100.0%) 7.3
bpeterson 2 (2.8%) 310 (58.6%) 155.0
allen 18 (25.0%) 130 (24.6%) 7.2
dav 6 (8.3%) 37 (7.0%) 6.1
jas 36 (50.0%) 24 (4.5%) 0.6
ahumphrey 9 (12.5%) 15 (2.8%) 1.6
harman 1 (1.4%) 13 (2.5%) 13.0

Most Recent Commits

allen 2016-10-14 15:59 Rev.: 55885

fixed boolean chaeck and added modified var mapper for saving vars in the timestep.xml file

1 lines of code changed in 2 files:

  • CCA/Components/ICE: ICE.cc (new)
dav 2016-09-19 17:47 Rev.: 55766

The main changes in this commit only effect a simulation when <outputNthProc> is
set (> 1) in the .ups file.

This commit allows for PIDX output on every process for a time step
output, while using every Nth process (if so specified) for UDA
checkpoint output. Eventually the need for this Nth Proc changing
hack (and Nth proc output itself) should go away when PIDX fully takes
over I/O.

Note, when using "Nth Process Output", both a checkpoint and a time step save
CANNOT occur on the same time step. Therefore the time step output is postponed
for one time step.

On a slightly different note, we use the term proc badly... we should use process,
or perhaps better yet, rank... as proc is usually taken to mean "processor", but
in MPI's case, means process - and the term MPI uses for process is rank.

D CCA/Ports/LoadBalancer.cc
D CCA/Ports/LoadBalancer.h
A + CCA/Ports/LoadBalancerPort.cc
A + CCA/Ports/LoadBalancerPort.h

- Renamed from LoadBalancer to LoadBalancerPort to avoid confusion with the LoadBalancer itself.
- Added "setNthProc()" so that the SimulationController can change the value as needed.

M CCA/Components/DataArchiver/DataArchiver.h
M CCA/Components/DataArchiver/DataArchiver.cc

- Added postponeNextOutputTimestep(). This pushes off the output of a time step by one
time step. (This occurs if using Nth Process Output and a checkpoint and a time step
where to occur on the same time step.)
- Added savingAsPIDX() boolean query function so that the SimulationController
can avoid doing all of this hack when we are not using PIDX.
- Removed "getCurrentTimestep()" and "getCurrentTime()", as, per the documentation on them,
they should not be used anyway; you should get this info from the shared state. Note,
the DataArchiver name (getCurrentTime()) is different from the shared state name
(getElapsedTime()) which was also confusing.
- Pass const string parameters by reference.
- White space cleanup / alignments.

- If the input file has no <save> labels, but specifies an output interval, throw an exception.
- If the 'logname' is not available when running a simulation, put 'unknown' instead of ignoring.
Should probably find a better fix then 'unknown', but that will have to wait for another day.
- Swat some evil endls. :)
- Don't calculate 'currsecs' on every process, just on rank 0.
- Removed all calls to usingMPI() as Alan deprecated it in a recent commit.
- procOnLevel is (I hope) a boolean array... so declare and use it as such.
- Don't name a variable with a single letter. n -> var_cnt

- Did I mention white space cleanups... Please for the sake of older eyes...

M CCA/Components/ICE/ICE.cc
M CCA/Components/Models/FluidsBased/AdiabaticTable.cc
M CCA/Components/Models/FluidsBased/NonAdiabaticTable.cc
M CCA/Components/Models/FluidsBased/NonAdiabaticTable.h
M CCA/Components/Models/FluidsBased/SimpleRxn.cc
M CCA/Components/Models/FluidsBased/SimpleRxn.h
M CCA/Components/Models/Radiation/RMCRT/Radiometer.cc
M CCA/Components/OnTheFlyAnalysis/MinMax.cc
M CCA/Components/OnTheFlyAnalysis/1stLawThermo.cc
M CCA/Components/OnTheFlyAnalysis/containerExtract.cc
M CCA/Components/OnTheFlyAnalysis/lineExtract.cc
M CCA/Components/OnTheFlyAnalysis/momentumAnalysis.cc
M CCA/Components/OnTheFlyAnalysis/particleExtract.cc
M CCA/Components/OnTheFlyAnalysis/planeExtract.cc
M CCA/Components/OnTheFlyAnalysis/statistics.cc

- Use shared state getElapsedTime()
- Naming conventions: sharedState -> d_sharedState (to match other class vars in file).
- White space / alignments / etc.

M CCA/Components/LoadBalancers/CostProfiler.cc

- White space separation of #includes between CCA and Core

M CCA/Components/Arches/PressureSolverV2.cc
M CCA/Components/Arches/Radiation/RadPetscSolver.cc
M CCA/Components/Examples/Poisson2.cc
M CCA/Components/Examples/DOSweep.cc
M CCA/Components/Examples/RMCRT_Test.cc
M CCA/Components/Examples/RegridderTest.cc
M CCA/Components/Examples/SolverTest1.cc
M CCA/Components/FVM/ElectrostaticSolve.cc
M CCA/Components/ICE/impAMRICE.cc
M CCA/Components/ICE/impICE.cc
M CCA/Components/LoadBalancers/CostProfiler.h
M CCA/Components/LoadBalancers/DynamicLoadBalancer.cc
M CCA/Components/LoadBalancers/ParticleLoadBalancer.cc
M CCA/Components/MPM/AMRMPM.cc
M CCA/Components/MPM/ImpMPM.cc
M CCA/Components/MPM/SerialMPM.cc
M CCA/Components/Parent/Switcher.cc
M CCA/Components/ReduceUda/UdaReducer.h
M CCA/Components/ReduceUda/UdaReducer.cc
M CCA/Components/Regridder/RegridderCommon.h
M CCA/Components/Regridder/RegridderCommon.cc
M CCA/Components/Regridder/SingleLevelRegridder.cc

- LoadBalancer -> LoadBalancerPort
- White space cleanup / alignments.

M CCA/Components/LoadBalancers/LoadBalancerCommon.h
M CCA/Components/LoadBalancers/LoadBalancerCommon.cc

- LoadBalancer -> LoadBalancerPort.
- Add setNthRank().
- getOutputProc() -> getOutputRank().
- Whitespace / alignment.
- Fix comment to indicate getOutputProc is returning an MPI rank.

M CCA/Components/LoadBalancers/ProfileDriver.h
M CCA/Components/LoadBalancers/ProfileDriver.cc
M CCA/Components/Regridder/TiledRegridder.cc
M CCA/Components/Schedulers/MPIScheduler.cc
M CCA/Components/Schedulers/SchedulerCommon.h
M CCA/Components/Schedulers/SchedulerCommon.cc

- Cosmetics: Whitespace / alignment / coding standards / alphabetize #includes / etc.
- LoadBalancer -> LoadBalancerPort

M CCA/Components/Schedulers/OnDemandDataWarehouse.h
M CCA/Components/Schedulers/OnDemandDataWarehouse.cc
M CCA/Components/Schedulers/Relocate.h
M CCA/Components/Schedulers/Relocate.cc

- Name class variables according to naming convention. (eg: aborted -> d_aborted).
- Be consistent with naming convention of class variables in same file.
- LoadBalancer -> LoadBalancerPort.

M CCA/Components/Schedulers/TaskGraph.h
M CCA/Components/Schedulers/TaskGraph.cc

- LoadBalancer -> LoadBalancerPort.
- White space. Name variable "subset" more accurately: "handling_rank". I don't know
why it was named "subset" to begin with as it doesn't appear to be a "set" to me...

M CCA/Components/Schedulers/UnifiedScheduler.cc

- White space.

M CCA/Components/SimulationController/AMRSimulationController.cc

- There are a lot of cosmetic cleanups in this file, but the real/main change is:
- Add in hack to handle changing from "nth process output" (for checkpoints) to
"1 process output" (for time steps) when running with PIDX (and nth process is > 1).
- Declare variables (start) where they are used, not at the top of a function.
- Move the terminal output of the 0th timestep out of the main simulation loop.
- White space / alignment / etc.
- LoadBalancer -> LoadBalancerPort.

M CCA/Components/SimulationController/SimulationController.h
M CCA/Components/SimulationController/SimulationController.cc
M CCA/Components/Solvers/AMR/AMRSolver.cc
M CCA/Components/Solvers/AMR/HypreDriver.cc
M CCA/Components/Solvers/AMR/HypreDriverStruct.cc
M CCA/Components/Solvers/CGSolver.cc
M CCA/Components/Solvers/HypreSolver.cc
M CCA/Components/Wasatch/Expressions/Coordinate.cc
M CCA/Components/Wasatch/Expressions/PoissonExpression.cc
M CCA/Components/Wasatch/Expressions/Pressure.cc
M CCA/Components/Wasatch/Expressions/RadiationSource.cc
M CCA/Components/Wasatch/Wasatch.cc
M CCA/Ports/Scheduler.h
M CCA/Ports/sub.mk
M Core/DataArchive/DataArchive.h
M Core/DataArchive/DataArchive.cc
M Core/Grid/Grid.h
M Core/Grid/Grid.cc
M Core/Grid/Level.h
M Core/Grid/Level.cc
M StandAlone/tools/uda2vis/uda2vis.cc

- LoadBalancer -> LoadBalancerPort.
- Cosmetic white space, alpha, etc.

M CCA/Ports/Output.h

- Removed getCurrentTimestep() and getCurrentTime() as the user should get
them from the shared state.
- Added postponeNextOutputTimestep().
- Added savingAsPIDX().



29 lines of code changed in 5 files:

  • CCA/Components/ICE: ICE.cc (+12 -12), impAMRICE.cc (+3 -3), impICE.cc (new)
allen 2016-08-16 15:35 Rev.: 55648

added debug streams and state vars

8 lines of code changed in 1 file:

  • CCA/Components/ICE: ICE.cc (+8 -4)
allen 2016-08-16 14:33 Rev.: 55646

backed out sim state changes

39 lines of code changed in 7 files:

  • CCA/Components/ICE: AMRICE.cc (new), AMRICE.h (new), ICE.cc (+27 -31), impAMRICE.cc (+2 -2), impICE.cc (+5 -5)
allen 2016-08-15 17:14 Rev.: 55638

cleanup of the simulation state - most everything is now private

43 lines of code changed in 5 files:

  • CCA/Components/ICE: AMRICE.cc (+4 -4), AMRICE.h (+1 -1), ICE.cc (+31 -27), impAMRICE.cc (+2 -2), impICE.cc (+5 -5)
jas 2016-07-20 12:18 Rev.: 55529

Add the HYPRE library, since impICE uses it.

0 lines of code changed in 2 files:

  • CCA/Components/ICE: sub.mk (new)
ahumphrey 2016-06-13 11:46 Rev.: 55440

Replace usage of NULL macro (type int) with nullptr (pointer literal of type: nullptr_t).

nullptr is implicitly convertible and comparable to any pointer type or pointer-to-member type, but is not implicitly comparable to integral types, except that it is convertible to bool (explicitly).

9 lines of code changed in 7 files:

  • CCA/Components/ICE: AMRICE.cc (+2 -2), AMRICE.h (+2 -2), BoundaryCond.cc (+1 -1), ICE.cc (+1 -1), impAMRICE.cc (+1 -1), impICE.cc (+2 -2)
ahumphrey 2016-06-07 09:19 Rev.: 55420

Removal of src/Core/Thread and related refactoring throughout the code-base.

This is the first step in a series of infrastrucutre overhauls to modernize Uintah. Though this all passes local RT (both CPU and GPU tests), I expect some fallout we haven't considered and will be standing by to deal with any issues. Once the dust settles, we will move to replacing Core/Malloc with jemalloc.

* We are now using the standard library for all multi-threading needs within the infrastructure, e.g. std::atomic, std::thread, std::mutex, etc.

* The Unified Scheduler is now the only multi-threaded scheduler, e.g. ThreadedMPIScheduler no longer exists (though the source will soon be placed into an attic).

* Threads spawned by the Unified Scheduler are detached by default (not joinable), allowing for easy, clean and independent execution. There are no longer ConditionVariables used to signal worker threads, just a simple enum for thread-state.

* What was Core/Thread/Time.* is now Core/Util/Time.* - a next step will be to migrate all internal timers, etc to use std::chrono.

* NOTE: Though much cleanup has occurred with this commit, there is still significant cleanup and formatting to be done. The scope of this commit neccessitates a more incremental approach.

6 lines of code changed in 2 files:

  • CCA/Components/ICE: ICE.cc (+5 -3), sub.mk (+1 -2)
harman 2016-06-02 15:23 Rev.: 55407

ICE, SerialMPM, MPMArches
- added machinery for calling AnalysisModule:outputProblemSpec()

OnTheFlyAnalysis (all modules)
- added virtual function outputProblemSpec
- added virtual function scheduleRestartInitialize()

ProblemSpec
- Added method findBlockWithAttributeValue()
<It should have been added years ago.>

Statistics.cc/h New Module:
Computes the 1st, 2nd, 3rd and 4th order moments over the entire domain

Computes u'v' u'w' v'w'

UPS spec:
<Module name = "statistics">
<timeStart> 0.001 </timeStart>
<timeStop> 100 </timeStop>
<material> Air </material>
<computeHigherOrderStats> true </computeHigherOrderStats>
<Variables>
<analyze label="press_CC" matl="0"/>
<analyze label="temp_CC" matl="1"/>
<analyze label="vel_CC" matl="1" computeReynoldsStress="true" />
</Variables> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
</Module>


13 lines of code changed in 1 file:

  • CCA/Components/ICE: ICE.cc (+13)
allen 2016-04-15 17:00 Rev.: 55196

add in-situ var reference and added comments

11 lines of code changed in 1 file:

  • CCA/Components/ICE: ICE.cc (+11 -4)
jas 2016-03-15 18:24 Rev.: 55024

Move non-conflicting classes that were in SCIRun namespace to Uintah namespace.

5 lines of code changed in 5 files:

  • CCA/Components/ICE: BoundaryCond.h (new), ICE.cc (+1 -1), customInitialize.cc (+1 -1)
dav 2016-03-14 00:56 Rev.: 55019

This commit changes the way Uintah checks for the file system it
will use to save UDAs. Previously (and still available via a
command line flag to sus) Uintah had every process create a file,
and then every other process look for (some of the files) in order
to determine if everyone was running on the same file system or on
a local system. Currently we don't use any machines that have
local (per node) disks, so we don't need to do this work and,
because on 100K+ jobs, this hammers the file system, can take
minutes, and possibly cause errors, we will now default to assuming
a shared file system (we do a single file check for this).

M CCA/Components/SimulationController/AMRSimulationController.cc

- Remove warning by putting VISIT var into #if HAVE_VISIT.

M CCA/Components/SimulationController/SimulationController.h
M CCA/Components/SimulationController/SimulationController.cc

- Store d_usingLocalFileSystems in the shared state.

M CCA/Components/MPM/ReactionDiffusion/NonLinearDiff1.cc

- Remove warning by putting unused var inside #if.

M CCA/Components/OnTheFlyAnalysis/MinMax.cc
M CCA/Components/ICE/ICE.cc

- Replace GetVisIt() with renamed getVisIt().

M CCA/Components/DataArchiver/DataArchiver.h
M CCA/Components/DataArchiver/DataArchiver.cc

- Main changes to file system check in this file.
- Re-wrote the check for a common FS in setupSharedFileSystem().
- Mostly has process 0 create a file and all the others look for it.
- Put old code that was in initializeOutput() into setupLocalFileSystems().

M CCA/Components/Schedulers/SingleProcessorScheduler.cc
M CCA/Components/Schedulers/UnifiedScheduler.cc
M CCA/Components/Schedulers/MPIScheduler.cc
M CCA/Components/Schedulers/ThreadedMPIScheduler.cc
M CCA/Components/Schedulers/DynamicMPIScheduler.cc

- Minor white space.

M CCA/Components/Schedulers/SchedulerCommon.h
M CCA/Components/Schedulers/SchedulerCommon.cc

- Update names of some class variables to be consistent (_) with
naming convention in file.
- OCD formatting.

M R_Tester/helpers/runSusTests.py
M R_Tester/toplevel/generateGoldStandards.py

- Fix generateGoldStandards check for correct version of python (need 2.7 or better).
- Update "print" statement to be "print()". This allows local RT python scripts
to run under python 3.

M Core/Grid/SimulationState.h
M Core/Grid/SimulationState.cc

- Added d_usingLocalFileSystems var. Few minor whitespace fixes.
- Uintah uses lower case letters to begin functions. Updated setVisIt() and getVisIt()).

M StandAlone/inputs/MPM/disks.ups

- Minor whitespace edit.

M StandAlone/sus.cc

- Check for/handle new command line arg: -local_filesystem
- Most likely no one will ever use this...
- As we do note have access to a system with local file systems, this has not been
tested but the code just passes through to the original code for checking
for a local FS.
- Minor whitespace / formatting.

8 lines of code changed in 1 file:

  • CCA/Components/ICE: ICE.cc (+8 -11)
allen 2016-02-09 14:37 Rev.: 54805

changed var name and added stop features

3 lines of code changed in 1 file:

  • CCA/Components/ICE: ICE.cc (+3 -3)
allen 2016-01-29 15:19 Rev.: 54751

added in an example of inserting in-situ vars from a component

25 lines of code changed in 1 file:

  • CCA/Components/ICE: ICE.cc (+25)
jas 2016-01-08 15:45 Rev.: 54640

Update copyright date to 2016.

19 lines of code changed in 29 files:

  • CCA/Components/ICE: AMRICE.cc (+1 -1), AMRICE.h (+1 -1), BoundaryCond.cc (+1 -1), BoundaryCond.h (+1 -1), ConservationTest.h (+1 -1), Diffusion.cc (+1 -1), Diffusion.h (new), ExchangeCoefficients.cc (+1 -1), ExchangeCoefficients.h (+1 -1), ICE.cc (+1 -1), ICE.h (+1 -1), ICEMaterial.cc (new), ICEMaterial.h (+1 -1), customInitialize.cc (+1 -1), customInitialize.h (+1 -1), impAMRICE.cc (+1 -1), impAMRICE.h (+1 -1), impICE.cc (+1 -1), sub.mk (+1 -1)
bpeterson 2016-01-04 18:21 Rev.: 54624

All updates from the gpu_dev branch merged back into trunk.

310 lines of code changed in 2 files:

  • CCA/Components/ICE: ICE.cc (+273 -39), ICE.h (+37)
Generated by StatSVN 0.7.0