[root]/CCA/Components/Arches/PropertyModelsV2
Author | Changes | Lines of Code | Lines per Change |
---|---|---|---|
Totals | 150 (100.0%) | 1742 (100.0%) | 11.6 |
jthornoc | 135 (90.0%) | 1253 (71.9%) | 9.2 |
harman | 9 (6.0%) | 472 (27.1%) | 52.4 |
spinti | 4 (2.7%) | 17 (1.0%) | 4.2 |
jholmen | 2 (1.3%) | 0 (0.0%) | 0.0 |
* Removed unused ArchesCore::OneDInterpolator setup.
0 lines of code changed in 2 files:
Change 1:
Moved the RMCRT radiometer into it’s own spec. This creates a clean line between RMCRT as a radiation model
and RMCRT as a radiometer from the input perspective. Behind the scenes, not much changed as RMCRT as the
radiometer still functions as a source term.
Change 2:
Implemented doInterpolation in the trunk that Derek had introduced in the kokkos branch. This reduces code
clutter and hopefully makes merging easier to the kokkos branch.
13 lines of code changed in 5 files:
Added modifier to particle scattering coefficient.
Removed NIGHTLYTESTS from list of LOCAL_TESTS in ARCHES.py
17 lines of code changed in 4 files:
*.ups
- changed label from abskt -> absk, to cut down on the confusion. The user can specify any
absorption coefficient.
Arches/SourceTerms/RMCRT.*
- renamed variables m_abskt -> m_absk_*
Arches/PropertyModelsV2/sumRadiation.cc
- problemSetup()
Added some confusing code to only add absk_name to the vector of names if it's unique.
We need to clearly define what abskt is and stick with that definition.
32 lines of code changed in 2 files:
Initialize some variables to avoid garbage in extra cells.
Update box1.ups input file.
Remove convection calc in extra cells for tangential vel comps. (will
cause RT failure due to diffs in extra cells).
Other general cleanup.
4 lines of code changed in 2 files:
Remove all traces of get_unmanaged field getters.
1 lines of code changed in 2 files:
Remove use of unmanaged field getter.
12 lines of code changed in 1 file:
Find and replace all: "new_get_uintah_field" is now "get_field"
303 lines of code changed in 41 files:
Updating these two files as there was a problem with a git merge and my
earlier commits. This should preserve Todds commit with the updated
variable getters.
109 lines of code changed in 2 files:
Final (?) cleanup of old variable getters. Old variable getters are now
commented out in TaskVariableTools and new getters are used everywhere.
75 lines of code changed in 5 files:
Fifth replacement of variable getters from TaskVariableTools.
This commit hits some of the getters with irregular spacing (thanks
RegEx).
35 lines of code changed in 5 files:
Fourth replacement of variable getters from TaskVariableTools.
This commit comments out one of the older getters in TaskVariableTools.
Note also that this was the first commit to handle pointers with the new
method in some cases.
138 lines of code changed in 17 files:
Third replacement of variable getters from TaskVariableTools.
37 lines of code changed in 10 files:
Second replacement of variable getters from TaskVariableTools.
60 lines of code changed in 10 files:
First commit using the new variable getter in TaskVariableTools.
43 lines of code changed in 9 files:
Formatting!!!
344 lines of code changed in 2 files:
Added Dout stream that outputs the variables that are used in the abskt calc.
Name change
_gas_part_name -> m_absk_names
Formattting
66 lines of code changed in 3 files:
Clearing up enum names.
26 lines of code changed in 11 files:
Removing the build_task function which is not needed anymore.
0 lines of code changed in 1 file:
Removing the storage of the ProblemSpec from the Unweight function. This
was leftover from the last large commit.
2 lines of code changed in 1 file:
Addressing multiple issues for the KokkosSolver in this commit:
1) Start with smarter naming of the Arches task names for easier debugging.
2) Clean up of code (removal of commented lines, etc)
3) Rearranging of a few things to facilitate heat loss calc. and table lookup
4) Trying to clean up some of the naming conventions in TransportFactory - more work needed
5) Starting to remove the build_all_tasks function and actually build them when initially parsing the input file to remove redundant parsing
6) Added a default momentum name
7) Removed some initialization loops in favor of the .initialize() function on grid variables. Hoping there will be kokkos/uintah backend support for this.
8) Added a “volumetric” scalar support - was there before but not explicitly.
9) Turning off computesWithScratchGhost in the dyn. model until the errant mpi errors can be sorted.
Answers on Kokkos Tests are affected because of one or more of the following:
- rho_star isn’t initialized at sched_Initialize to the density value. There was no value in doing this and it created a task ordering problem.
- Different numbers of variables in checkpoint
- Fuzz differences in the helium tests
Otherwise the grid refinement verification studies passed, which are run manually.
352 lines of code changed in 8 files:
problemSetup()
- simplified bullet proofing which checks for a consistent abskt label for each radiation model.
- multiple radiation src terms are now allowed.
30 lines of code changed in 2 files:
The parenthesis on these ternary statements were messed up resulting in
an abs() on a bool.
Thanks Allen for pointing out the warning.
13 lines of code changed in 1 file:
Adding an input file that computes closure on a frozen vel field.
Had to edit spec and VarInterpolation class to get this to work.
3 lines of code changed in 2 files:
Cleaning up the summation model a bit.
27 lines of code changed in 2 files: