[root]/CCA/Components/Arches/Utility
Author | Changes | Lines of Code | Lines per Change |
---|---|---|---|
Totals | 68 (100.0%) | 394 (100.0%) | 5.7 |
jthornoc | 65 (95.6%) | 389 (98.7%) | 5.9 |
ohdiazi | 1 (1.5%) | 3 (0.8%) | 3.0 |
harman | 2 (2.9%) | 2 (0.5%) | 1.0 |
Find and replace all: "new_get_uintah_field" is now "get_field"
88 lines of code changed in 24 files:
Fifth replacement of variable getters from TaskVariableTools.
This commit hits some of the getters with irregular spacing (thanks
RegEx).
3 lines of code changed in 1 file:
Fourth replacement of variable getters from TaskVariableTools.
This commit comments out one of the older getters in TaskVariableTools.
Note also that this was the first commit to handle pointers with the new
method in some cases.
26 lines of code changed in 8 files:
Third replacement of variable getters from TaskVariableTools.
25 lines of code changed in 5 files:
Second replacement of variable getters from TaskVariableTools.
18 lines of code changed in 5 files:
First commit using the new variable getter in TaskVariableTools.
16 lines of code changed in 4 files:
Clearing up enum names.
3 lines of code changed in 1 file:
Fixing an issue where two enums had the same name causing undefined
behavior with the compiled exe.
5 lines of code changed in 2 files:
Warning.
0 lines of code changed in 2 files:
Encapsulating the Sandbox and SSPRK solvers a little better.
Added a test of the linear solver in the Sandbox and cleared out what was there before.
16 lines of code changed in 2 files:
Removing the build_task function which is not needed anymore.
2 lines of code changed in 3 files:
Addressing multiple issues for the KokkosSolver in this commit:
1) Start with smarter naming of the Arches task names for easier debugging.
2) Clean up of code (removal of commented lines, etc)
3) Rearranging of a few things to facilitate heat loss calc. and table lookup
4) Trying to clean up some of the naming conventions in TransportFactory - more work needed
5) Starting to remove the build_all_tasks function and actually build them when initially parsing the input file to remove redundant parsing
6) Added a default momentum name
7) Removed some initialization loops in favor of the .initialize() function on grid variables. Hoping there will be kokkos/uintah backend support for this.
8) Added a “volumetric” scalar support - was there before but not explicitly.
9) Turning off computesWithScratchGhost in the dyn. model until the errant mpi errors can be sorted.
Answers on Kokkos Tests are affected because of one or more of the following:
- rho_star isn’t initialized at sched_Initialize to the density value. There was no value in doing this and it created a task ordering problem.
- Different numbers of variables in checkpoint
- Fuzz differences in the helium tests
Otherwise the grid refinement verification studies passed, which are run manually.
143 lines of code changed in 7 files:
Updates to the mass_flow_rate monitor. Adding documentation and removing
the print statement since it was only printing for proc0, which lead to
misleading results when the inlets do not reside on a patch associated
with proc0. Also renamed the variables to be more explicit as to what
the particle flow rate actually represents (organics, not mass of entire
particle.)
44 lines of code changed in 1 file:
Fixing print statement
3 lines of code changed in 1 file:
Updated Copyright date
2 lines of code changed in 2 files: